Org.BouncyCastle.Tls.AbstractTlsServer
Base class for a TLS server.
Whether to echo a client's "status_request" extension (RFC 6066 sec. 8) in the extended server hello,
so that a stapled OCSP response can be sent.
Whether to echo a client's "status_request_v2" extension (RFC 6961 sec. 2.2) in the extended server
hello.
RFC 9146 DTLS connection ID.
protected virtual bool IsSelectableCipherSuite(int cipherSuite, int availCurveBits, int availFiniteFieldBits, IList<short> sigAlgs)
public virtual void ProcessClientSupplementalData(IList<SupplementalDataEntry> clientSupplementalData)
protected virtual ProtocolName SelectProtocolName(IList<ProtocolName> clientProtocolNames, IList<ProtocolName> serverProtocolNames)