Org.BouncyCastle.Asn1.X509.KeyPurposeID
The KeyPurposeID object.
RFC 9174 sec. 4.4.1 - Delay-Tolerant Networking bundle security (TCPCLv4).
RFC 9809 sec. 3 - signing general-purpose configuration files.
RFC 9336 sec. 3.1 - signing documents (e.g. PDF, XML, JSON) for human consumption.
RFC 9509 sec. 3 - encrypting JSON objects in HTTP messages between 5G Security Edge Protection Proxies
(SEPPs) using JWE.
RFC 9734 sec. 3 - proving the identity of an Instant Messaging (IM) client, whose IM URI (RFC 3860) or XMPP
URI (RFC 6121) appears in the subjectAltName.
RFC 9509 sec. 3 - signing the JWT Claims Set of a Client Credentials Assertion (CCA) using JWS, for 5G
Network Function service consumers.
Microsoft Server Gated Crypto (msSGC).
Netscape Server Gated Crypto (nsSGC).
RFC 9509 sec. 3 - signing OAuth 2.0 access tokens for service authorization using JWS, as issued by a 5G
Network Repository Function (NRF).
RFC 9809 sec. 3 - authenticating communication peers for safety-critical communication.
RFC 9809 sec. 3 - signing trust anchor configuration files.
RFC 9809 sec. 3 - signing software or firmware update packages.