<PackageReference Include="BouncyCastle.Cryptography" Version="2.8.0-beta.349" />

Org.BouncyCastle.Tls.TlsServer

public interface TlsServer : TlsPeer
Interface describing a TLS server endpoint.

This method will be called (only) if StatusRequestVersion is non-zero, meaning the client asked for a stapled response and the server undertook to answer: up to(D)TLS 1.2, that it echoed an extension of type "status_request" (RFC 6066 sec. 8. Certificate Status Request) or "status_request_v2" (RFC 6961 sec. 2.2. Multiple Certificate Status Request Record) with empty "extension_data" in the extended server hello; in TLS 1.3, simply that the client offered "status_request".

Return server credentials to use.

Return the TlsPskExternalexternal PSK to select from the ClientHello.

byte[] GetNewSessionID()

RFC 5077 3.3. NewSessionTicket Handshake Message.

void GetServerExtensionsForConnection(IDictionary<int, byte[]> serverExtensions)

TlsSession GetSessionToResume(byte[] sessionID)

Return the specified session, if available.

void Init(TlsServerContext context)

void NotifyClientCertificate(Certificate clientCertificate)

Called by the protocol handler to report the client certificate, only if GetCertificateRequest returned non-null.

void NotifyFallback(bool isFallback)

void NotifyOfferedCipherSuites(int[] offeredCipherSuites)

void NotifySession(TlsSession session)

void ProcessClientExtensions(IDictionary<int, byte[]> clientExtensions)