Org.BouncyCastle.Asn1.X509.KeyPurposeID
The KeyPurposeID object.
RFC 9809 sec. 3 - signing general-purpose configuration files.
RFC 9336 sec. 3.1 - signing documents (e.g. PDF, XML, JSON) for human consumption.
RFC 9734 sec. 3 - proving the identity of an Instant Messaging (IM) client, whose IM URI (RFC 3860) or XMPP
URI (RFC 6121) appears in the subjectAltName.
Microsoft Server Gated Crypto (msSGC).
Netscape Server Gated Crypto (nsSGC).
RFC 9809 sec. 3 - authenticating communication peers for safety-critical communication.
RFC 9809 sec. 3 - signing trust anchor configuration files.
RFC 9809 sec. 3 - signing software or firmware update packages.